24 October 2012

Re-installing MCX

While attempting to repair a problem with a clients self installed Lync FE IIS services I came to the conclusion that the Web Components Services was broken. No problem, right?
Simply uninstall the Web Components and then re-run the Deployment Wizard. I did that and returned to IIS to see MCX now missing. Suppose I should have expected that. No problem (again), I'll just run the MCXStandalone.msi...
So the .msi says that the MCX is still installed, did a remove and ran it again to re-install. Done.

Checked IIS and MCX has returned, only problem is it still doesn't work when I run the www.testocsconnectivity.com test.

So what's the issue?
For one thing, the Environment had been installed and updated to CU6 but the MCXStandalone was still on the relative CU4. The MCX Update was found here

Secodly I assumed that the MCX listening ports were still defined as you usually cant install the MCX if they aren,t. Better safe than sorry, so I re-ran them too

Set-CsWebServer -Identity <SE FQDN> -McxSipPrimaryListeningPort 5086
Set-CsWebServer –Identity <SE FQDN> -McxSipExternalListeningPort 5087

I restarted all the services for good measure, probably wasn't necessary.

And voila!

18 October 2012

Troubleshooting Address Book Service issues

The culprit.

 Generally speaking the ABS can be problematic from a client or server perspective. I usually start with the client, working my way up from there.

Ask yourself, self...
Is the Cannot Syncronize the Address Book error experienced by all or just one\few individualy?

If its just a few it may be a local issue

Simply to delete the local GalContacts.db and GalContacts.db.idx files. You could then wait and after a raondom time from 1 - 30 minutes (default 30 minutes) you should get a new GAL.
If not check to see if the client can navigate to the ABS URL's (Seen from configuration information)- often been the problem

What if its Server Related?
The client side GAL files are downloded from the Lync FE IIS. The URL is visible from the Communicator Configuration information (SHIFT + Rightclick icon).

There will be an internal and external URL depending on where the client is connecting from. The URLS look similar to this:-

URL Internal From Server https://FE.lynclab.local:443/abs/handler
URL External From Server https://FE.lynclab.co.nz:443/abs/handler

Firstly you can test to see if you can reach these. URL needs to be valid and reachable (proxy issues?etc)
Both sites should present you with an authentication Required box asking for username and password, if you see this the URL is working.

The data located in the backend of the url is situated on the Lync Share that was created during the install process. Ensure that the share is still valid by navigating to it from one of the clients (clients should have read access).

If for some reason the file share is no longer shared or the rights to the share and even the file structure in the share has changed...
You can remedy this by re-publishing the Topology followed by running the Deployment Wizard.

The Lync share needs to have the following 3 files:-

The time and date stamp on these indicates when they were initially created.
The file structure ia as below.

The second level 00000000-0000-0000-0000-000000000000 folder should be time stamped with the last time the AddressBookService was updated (with approximatly 5 minutes added to it).

You could run a Update-CsAddressbook PS command and after about 5 minutes the folder should be updated.

An error I can across recently, the client reported that the "Corporate Address book file appears to be damaged"

Deleting the second level 00000000-0000-0000-0000-000000000000 folder removes the corrupt file. Simply running another Update-CsAddressbook PS command will recreate the folder and its contents.

If the IIS bits are misbehaving its probably best not to fiddle with tnem as the rights, paermissions and accounts required are configured by the installer. What you could try is uninstall lync web component module (control pannel > uninstall ...), delete web component directory (C:\Program Files\Microsoft Lync Server 2010\Web Components) then reinstall web component through lync deployment wizard.